Choose style:

Author Topic: [SOLVED] R066 - Connecting outbound to external IPSec VPN issues  (Read 4832 times)

0 Members and 1 Guest are viewing this topic.

Offline pitchdarkice

  • Backer
  • *
  • Posts: 13
  • Thanks: 0
  • Registered : 02/08/2013
    YearsYearsYearsYearsYearsYearsYearsYearsYears
[SOLVED] R066 - Connecting outbound to external IPSec VPN issues
« on: September 19, 2014, 07:40:02 pm »
It looks like with R066 you introduced ALG again.  With ALG introduced, now I can't connect externally to IPSec vpns.  I've tried both iterations enable IPSec and disable IPSec to no avail.  I also rebooted the router after each setting.  By default it comes uncheck.  Either case I can no longer connect to the VPN.  This issue was here originally when the first almond+ firmware was released, but I was able to fix it by doing the opposite of whatever the default setting was.  Now this doesn't work either, rendering the R066 pretty much useless to me from a work standpoint.
« Last Edit: September 20, 2014, 01:23:27 am by pitchdarkice »

jjoepaulines

  • Guest
Re: R066 - Connecting outbound to external IPSec VPN issues
« Reply #1 on: September 19, 2014, 09:54:45 pm »
disable the option through commend line ... ALG option is disable by default in R66 ... May be old configuration file messing the things


Follow the steps below ..

1. Disable the ALG  in openwrt UI

2. Type
Code: [Select]
/etc/init.d/algapp disable in ALmond Plus terminal [ use ssh to access almond plus terminal ]

3.Then do reboot.

----
Factory reset will fix this problem . if you don't want to losses the old setting,Please Follow the above steps

Offline pitchdarkice

  • Backer
  • *
  • Posts: 13
  • Thanks: 0
  • Registered : 02/08/2013
    YearsYearsYearsYearsYearsYearsYearsYearsYears
Re: R066 - Connecting outbound to external IPSec VPN issues
« Reply #2 on: September 19, 2014, 10:24:48 pm »
disable the option through commend line ... ALG option is disable by default in R66 ... May be old configuration file messing the things


Follow the steps below ..

1. Disable the ALG  in openwrt UI

2. Type
Code: [Select]
/etc/init.d/algapp disable in ALmond Plus terminal [ use ssh to access almond plus terminal ]

3.Then do reboot.

----
Factory reset will fix this problem . if you don't want to losses the old setting,Please Follow the above steps

I tried the suggestion above with disabling ALG and it didn't work.  I then did a factory reset, still doesn't work.  Either setting, checked or uncheck.  All of this was fine with R065.

jjoepaulines

  • Guest
Re: R066 - Connecting outbound to external IPSec VPN issues
« Reply #3 on: September 19, 2014, 10:50:43 pm »
did you try "/etc/init.d/algapp disable" before .. if not please try this

jjoepaulines

  • Guest
Re: R066 - Connecting outbound to external IPSec VPN issues
« Reply #4 on: September 19, 2014, 11:08:31 pm »
Please remove the ipsec.rule that we have in "/etc/alg-rules"

Type

Code: [Select]
rm /etc/alg-rules/ipsec.rules
then

Code: [Select]
luci-reload firewall

This will work..

i verified it works.

Offline pitchdarkice

  • Backer
  • *
  • Posts: 13
  • Thanks: 0
  • Registered : 02/08/2013
    YearsYearsYearsYearsYearsYearsYearsYearsYears
Re: R066 - Connecting outbound to external IPSec VPN issues
« Reply #5 on: September 20, 2014, 01:23:05 am »
Please remove the ipsec.rule that we have in "/etc/alg-rules"

Type

Code: [Select]
rm /etc/alg-rules/ipsec.rules
then

Code: [Select]
luci-reload firewall

This will work..

i verified it works.

Thanks Joe.

This process worked for me.  I am now able to connect to my IPSec vpn.  Rather than delete the ipsec.rules I just renamed it to ipsec.rules.disabled

Offline Franz29

  • Backer
  • *
  • Posts: 11
  • Thanks: 0
  • Registered : 02/09/2014
    YearsYearsYearsYearsYearsYearsYearsYears
Re: [SOLVED] R066 - Connecting outbound to external IPSec VPN issues
« Reply #6 on: September 22, 2014, 09:15:28 am »
Ignore this, seem to have fixed it.
« Last Edit: September 22, 2014, 09:21:22 am by Franz29 »

Offline jasmun88

  • Backer
  • *
  • Posts: 8
  • Thanks: 0
  • Registered : 18/08/2014
    YearsYearsYearsYearsYearsYearsYearsYears
VPN on R066
« Reply #7 on: September 25, 2014, 06:02:12 am »
Has anyone been able to get the vpn server working on the R066 firmware? Did you have to any firewall rules or anything?

LGNilsson

  • Guest
Re: [SOLVED] R066 - Connecting outbound to external IPSec VPN issues
« Reply #8 on: September 24, 2014, 11:42:24 pm »
Topics merged.

Offline fahrennheit451

  • Newbie
  • Posts: 1
  • Thanks: 0
  • Registered : 10/10/2014
    YearsYearsYearsYearsYearsYearsYearsYears
Re: [SOLVED] R066 - Connecting outbound to external IPSec VPN issues
« Reply #9 on: October 10, 2014, 07:02:24 pm »
I still cannot use IPSec VPN from behind my Almond+.  I've followed Joe's instructions, and have even factory-reset the router, without luck.  Any other ideas?

 

Page created in 0.047 seconds with 17 queries.