Choose style:

Author Topic: How do I configure WLAN access to the Almond+?  (Read 1328 times)

0 Members and 1 Guest are viewing this topic.

Offline Ehryk

  • Backer
  • *
  • Posts: 19
  • Thanks: 0
  • Registered : 06/08/2014
    YearsYearsYearsYearsYears
How do I configure WLAN access to the Almond+?
« on: January 06, 2015, 01:16:24 pm »
I can access my Almond+ GUI from port 80 from the web AS LONG AS I DON'T ADD A PORT FORWARD to :80.

I cannot access OpenWRT (:90) from outside my network.

1) How can I configure the ports that the web interfaces run on (:80 and :90 by default)
2) How can I configure which ones are LAN only, or WLAN+LAN (accessible from outside my network)

Is this going to be SSHing in to edit some config files? If so,

3) Are they planned for addition to the GUI?

Thanks!

Offline j8048188

  • Backer
  • *
  • Posts: 108
  • Thanks: 0
  • Registered : 12/08/2014
    YearsYearsYearsYearsYears
Re: How do I configure WLAN access to the Almond+?
« Reply #1 on: January 07, 2015, 09:29:51 am »

Offline Ehryk

  • Backer
  • *
  • Posts: 19
  • Thanks: 0
  • Registered : 06/08/2014
    YearsYearsYearsYearsYears
Re: How do I configure WLAN access to the Almond+?
« Reply #2 on: January 07, 2015, 01:39:07 pm »
It's not port forwarding I'm after, it's changing the ports that the Almond itself is using for things. I think I found most of them:

Open :90 through the firewall:
/etc/config/firewall
----------------------
add:
config 'rule'
    option 'target' 'ACCEPT'
    option 'src' 'wan'
    option 'proto' 'tcp'
    option 'dest_port' '90'
    option 'name' 'Remote OpenWRT'

/etc/lightppd/lightppd.conf
-------------------------------
change `server.port = 80` to whatever port you want the Almond GUI on
change `$SERVER["socket"] == ":90"{` to whatever you want the OpenWRT to run on

Note that I haven't tested changing the ports yet, but opening up :90 worked for getting to OpenWRT from outside the network.

 

Page created in 0.046 seconds with 21 queries.