Choose style:

Author Topic: Almond Repeater issues with new Modem  (Read 4960 times)

0 Members and 1 Guest are viewing this topic.

Offline dethkrik

  • Newbie
  • Posts: 1
  • Thanks: 0
  • Registered : 30/04/2015
Almond Repeater issues with new Modem
« on: April 30, 2015, 01:32:25 pm »
Greetings, thanks for any assistance available.

I had my Almond setup as a Repeater for over a year. Aside from occasional WIFI interference issues, it worked great. However, about 2 weeks ago, my ISP came and 'upgraded' the modem. Ever since then, the Almond see's the modem as an available connection, connects successfully, but then when it goes to the 'Connection' screen, it shows:

Cloud - X - Modem - Green Broadcast - Almond

There were times when I could still get my computer to access the internet (despite that red X). However for the past 2 days all I get are "DNS Lookup" errors and can't access anything. I've tried Factory Resetting. Firmware is updated to R200. I've powercycled the modem, Almond, and my PC multiple times, without any success. 

The computer physically connected to the modem accesses the internet fine. Other devices connecting to the modem don't seem to have this issue. Laptops connect to the modem and access the internet fine. The Smart TV can access the modem fine. It seems to be an issue specific to the connection between the modem and the Almond. Any sort of help with getting the proper settings on the Modem and/or Almond to get the connection working properly would be greatly appreciated.


  • Guest
Re: Almond Repeater issues with new Modem
« Reply #1 on: April 30, 2015, 04:11:01 pm »
You email has been received by our support team. Some one would reply back to you before end of day today.

"Cloud - X - Modem - Green Broadcast - Almond"

We are aware of this visual bug, where though connected the Almond shows a red X when used as Range Extender. This doesn't effect the functionality of the device at all and this visual mis-representation would be fixed in upcoming software update. To ensure your device is working correctly, refer to "Status" app on the home screen. If its connected there, Almond is functioning normal[

Offline jhaigh

  • Newbie
  • Posts: 1
  • Thanks: 0
  • Registered : 02/05/2015
Re: Almond Repeater issues with new Modem
« Reply #2 on: May 02, 2015, 09:27:40 pm »
I'm having the same issue as the original poster.  Almond is not functioning as a repeater at all, even after factory reset, update,  and repeated reboots.  Devices can connect to the Almond, but Internet will not work.  Internet works off of the other router, but it not repeated through the Almond.  This all started after a power outage a week ago. 

Offline Ashok

  • Securifi Staff
  • *
  • Posts: 2770
  • Thanks: 3
  • Registered : 25/07/2014
Re: Almond Repeater issues with new Modem
« Reply #3 on: May 02, 2015, 09:35:34 pm »
@ jhaigh,

Make sure you have the updated software (R200) on the Almond, if not please update and then connect it back in Range Extender mode by performing a factory reset.

If you are still facing the same issue then please tap on Status and let us know if it says "Internet Connected" or "Internet Disconnected".


Page created in 0.051 seconds with 18 queries.