Choose style:

Author Topic: Need help w/ OpenVPN client  (Read 3443 times)

0 Members and 1 Guest are viewing this topic.

Offline Artik

  • Backer
  • *
  • Posts: 13
  • Thanks: 0
  • Registered : 07/09/2013
    YearsYearsYearsYearsYearsYearsYearsYears
Need help w/ OpenVPN client
« on: April 16, 2016, 01:20:51 pm »
Hi! Has anyone had any success with OpenVPN client and commercial public VPNs? I tried a few with trial versions but I can never get them to connect. Most supply their settings as .ovpn files - I tried both copying what I could decipher to web interface and just launching openvpn --config <file>.ovpn through putty - nothing seems to work. Web interface is stuck at "still trying to connect", command line gets to "initialization completed", but I can't get any page to open from ethernet-connected PC. Doesn't seem to be a DNS problem, since IPs don't work either. Though I may be unaware of some additional steps apart from what is set up directly in openVPN menu?
So can anyone recommend a service they were able to set up connection for? Or maybe give some pointers as to what may be going wrong?

Offline Ashok

  • Securifi Staff
  • *
  • Posts: 2770
  • Thanks: 3
  • Registered : 25/07/2014
    YearsYearsYearsYearsYearsYearsYears
Re: Need help w/ OpenVPN client
« Reply #1 on: April 16, 2016, 09:16:01 pm »
@ Artik,

Ensure that we are receiving the direct WAN IP to the Almond+ and it is setup in Router mode. Even the extra space would cause the issue, hence, make sure that every field is filled properly, then reboot the Almond+ once and then try again.

Offline mr_tom

  • Acorn
  • *
  • Posts: 5
  • Thanks: 0
  • Registered : 05/09/2014
    YearsYearsYearsYearsYearsYearsYears
Re: Need help w/ OpenVPN client
« Reply #2 on: April 18, 2016, 11:46:07 pm »
Hi there,

I'm also having this issue. Fairly confident that the various OpenVPN settings are good, as they're working on my laptop.
The Almond+ has an IP addr from the internet and is routing traffic as normal.

Any more suggestions? Is there someone sensible to look for logs?

Offline Rahaman

  • Securifi Staff
  • *
  • Posts: 78
  • Thanks: 4
  • Registered : 11/01/2015
    YearsYearsYearsYearsYearsYears
Re: Need help w/ OpenVPN client
« Reply #3 on: April 20, 2016, 09:17:04 am »
Hi! Has anyone had any success with OpenVPN client and commercial public VPNs? I tried a few with trial versions but I can never get them to connect. Most supply their settings as .ovpn files - I tried both copying what I could decipher to web interface and just launching openvpn --config <file>.ovpn through putty - nothing seems to work. Web interface is stuck at "still trying to connect", command line gets to "initialization completed", but I can't get any page to open from ethernet-connected PC. Doesn't seem to be a DNS problem, since IPs don't work either. Though I may be unaware of some additional steps apart from what is set up directly in openVPN menu?
So can anyone recommend a service they were able to set up connection for? Or maybe give some pointers as to what may be going wrong?


Hi there,

I'm also having this issue. Fairly confident that the various OpenVPN settings are good, as they're working on my laptop.
The Almond+ has an IP addr from the internet and is routing traffic as normal.

Any more suggestions? Is there someone sensible to look for logs?

Please check the link below, go through the steps mentioned there. Hopefully it will work.

https://forum.securifi.com/index.php/topic,3935.msg19604.html#msg19604
« Last Edit: April 20, 2016, 09:21:27 am by Rahaman »

Offline Artik

  • Backer
  • *
  • Posts: 13
  • Thanks: 0
  • Registered : 07/09/2013
    YearsYearsYearsYearsYearsYearsYearsYears
Re: Need help w/ OpenVPN client
« Reply #4 on: April 21, 2016, 01:58:18 pm »

Please check the link below, go through the steps mentioned there. Hopefully it will work.

https://forum.securifi.com/index.php/topic,3935.msg19604.html#msg19604
That post is what I started from - without it I wouldn't know what to copy where. Regarding what Ashok said, one potential problem I noticed right away were windows paragraphs instead of linux paragraphs when copy-pasting certificates. But eventually I got around that with notepad++ settings (checked the result in vi through putty - yes, the extra characters were gone). But it didn't help.

Offline Rahaman

  • Securifi Staff
  • *
  • Posts: 78
  • Thanks: 4
  • Registered : 11/01/2015
    YearsYearsYearsYearsYearsYears
Re: Need help w/ OpenVPN client
« Reply #5 on: April 27, 2016, 08:13:47 am »
That post is what I started from - without it I wouldn't know what to copy where. Regarding what Ashok said, one potential problem I noticed right away were windows paragraphs instead of linux paragraphs when copy-pasting certificates. But eventually I got around that with notepad++ settings (checked the result in vi through putty - yes, the extra characters were gone). But it didn't help.

Okk....!!!
I think it would be better if you could contact our support team, to work with our software team, we will look into your device what really happening when you start Open VPN and take care of it accordingly. 

 

Page created in 0.094 seconds with 19 queries.