Choose style:

Author Topic: Almond+ bugs (broken UPnP or NAT)  (Read 2499 times)

0 Members and 1 Guest are viewing this topic.

Offline syxbit

  • Backer
  • *
  • Posts: 5
  • Thanks: 0
  • Registered : 06/08/2013
Almond+ bugs (broken UPnP or NAT)
« on: March 16, 2015, 01:31:35 am »
I moved house last week, switching from Fiber to Comcast  :(.
As I was without internet for a while, there were lots of firmware updates to do. Almond+, PS4, Printer etc...
I mistakenly updated them right away. Everything seemed fine for the first few days, until I tried to download a game on my PS4, or stream a video (youtube or netflix) through chromecast. Neither would work.
I thought it could be Comcast, or my new Motorola SB6183 modem (or one of the firmware updates I did). Everything on Google talked about needing to enable UPnP, NAT, AP, DMZ, port forwarding certain ports etc.. I tried it all. nothing worked. In fact, I reset the Almond+ multiple times while troubleshooting. Nothing I did mattered.

Finally, I dug out and plugged in my old Asus RT-N66u (running TomatoUSB), and it (ps4 and chromecast) worked right away. Needless to say, I'm extremely annoyed. I just wasted 8 hours on what is almost certainly an Almond+ bug.

I was initially fairly happy with my Almond+ purchase, as despite abysmal 5GHz performance/stability, it was a cool gadget that worked pretty well, and had future promise. What I realized this week though, is that my router is absolutely central to everything. A router bug can cause havoc to every gadget in my house. Just searching the forums show numerous similar issues, and I'm not sure.

So, is this a known bug?

Offline Atlanta

  • Newbie
  • Posts: 2
  • Thanks: 0
  • Registered : 29/09/2015
Re: Almond+ bugs (broken UPnP or NAT)
« Reply #1 on: September 29, 2015, 09:36:27 pm »
Thanks for your post.  I was about to waste another day trying to figure out why my PS4 and Chromecast wasn't working. Did a factory reset on my PS4 and lost PT... pissed at this router now.

Offline Ashok

  • Securifi Staff
  • *
  • Posts: 2770
  • Thanks: 3
  • Registered : 25/07/2014
Re: Almond+ bugs (broken UPnP or NAT)
« Reply #2 on: September 30, 2015, 09:45:58 am »
We have no known issues about PS4 or Chromecast not connecting to the Almond+. However, please get in touch with our support team at  ( who can take care of the issue for you. 


Page created in 0.123 seconds with 18 queries.