Choose style:

Author Topic: R83 Feedback / Issues  (Read 33153 times)

0 Members and 1 Guest are viewing this topic.

Offline Paholainen

  • Newbie
  • ***
  • Posts: 39
  • Thanks: 0
  • Registered : 02/11/2014
    YearsYearsYearsYearsYearsYearsYearsYears
Re: R83 Feedback / Issues
« Reply #45 on: January 06, 2016, 01:59:23 pm »
@Ashok
Did you get my log files? sent them a while ago. Also the rules is not working properly since update. A light is supposed to switch on when motion is sensed (worked fine on previous FW) but now it doesn´t always turn on, especially if it has recently turned off, it takes a long time before it turns on again, and sometimes the light is not on for the set duration.

Offline Ashok

  • Securifi Staff
  • *
  • Posts: 2770
  • Thanks: 3
  • Registered : 25/07/2014
    YearsYearsYearsYearsYearsYearsYearsYears
Re: R83 Feedback / Issues
« Reply #46 on: January 07, 2016, 07:42:31 am »
@ Paholainen,

Yes, and as per the log files we did not find any issue with the Fibaro. Is it possible for you to remove and add the Fibaro once and check.

See if you can replicate the issue with the Rules and then send the log files which would give us some information on what is causing it.

Offline spooky123

  • Backer
  • *
  • Posts: 129
  • Thanks: 0
  • Registered : 30/09/2014
    YearsYearsYearsYearsYearsYearsYearsYears
Re: R83 Feedback / Issues
« Reply #47 on: January 07, 2016, 08:14:23 am »
@Ashok - can logs be generated from the web interface or android app?

Offline Ashok

  • Securifi Staff
  • *
  • Posts: 2770
  • Thanks: 3
  • Registered : 25/07/2014
    YearsYearsYearsYearsYearsYearsYearsYears
Re: R83 Feedback / Issues
« Reply #48 on: January 07, 2016, 08:23:53 am »
@ spooky123,

Yes, using the latest android app you can send the log files.

Offline SecureComp

  • Backer
  • *
  • Posts: 541
  • Thanks: 1
  • Registered : 05/08/2014
    YearsYearsYearsYearsYearsYearsYearsYears
Re: R83 Feedback / Issues
« Reply #49 on: January 09, 2016, 11:24:08 am »
ISSUE with RULES:
(Rule #30) in my case
Have a Rule setup to Turn on Lights IF Between 6AM-3:59PM AND Device X Joins THEN Turn ON a bunch of Inside Lights, Turn OFF Outside Lights, Set Mode to Home

Expected Result:
Arrive home anytime between 6AM-3:59PM, smartphone joins network, lights set, Home mode set.

What IS Happening:
Every morning at 6AM, All my lights are turning ON and outside lights are turning OFF. (smartphone has been connected to network all night)
Also
Rule works for when I arrive home anytime between 6-3:59, it's just all the lights coming on every day a 6AM that's a problem.

Sending logs tagged "@securecomp waking up every day at 6 because lights on"

snip from runRule.log
Code: [Select]
[2016-1-9 6:0:1.283793437] {PRINT} <================================runRule started=================================>
[2016-1-9 6:0:1.297905849] {PRINT} False in the range1
[2016-1-9 6:0:1.307612622] {PRINT} executing Rule 30 for AND condition is success
[2016-1-9 6:0:1.307789036] {PRINT} setting Job after 1 seconds for Rule 30 Result 1
« Last Edit: January 09, 2016, 11:26:15 am by SecureComp »
Kickstarter Backer
Securifi Wiki Editor and Beta Tester, Not a Securifi employee
Almond+, many sensors, IOS App, Android Apps and Widgets

Offline fillibar

  • Backer
  • *
  • Posts: 2060
  • Thanks: 4
  • Registered : 02/08/2013
    YearsYearsYearsYearsYearsYearsYearsYearsYears
Re: R83 Feedback / Issues
« Reply #50 on: January 09, 2016, 05:47:19 pm »
@SecureComp:
That sounds like expected result to me. The presence sensing function acts more like a statement of "joined" not "joins" (like some of the text). So the rule you have set is acting more like:
IF Between 6am and 3:59pm AND Device X is joined/on the network THEN Turn On a bunch of lights, etc...

Your device is on the network all night. At 6am it is STILL on the network (joined to it) so the rule triggers. The current functionality is truly a presence sensor, are you on the network or not, versus an immediate action of such. So Rules that do not care whether it stays around work fine (If Device X Joins Then Set Home Mode, which I use by the way).

A way to create the "correct" effect might be:
IF Between 6am and 3:59pm And Mode is Away And Device Joins THEN Turn on lights, etc... This assumes you set your home to Away when your device leaves the network. So if the device does not leave the network (you are still home) it would not trigger because your home is in home mode.
Almond 3 mesh handling the home.

Offline SecureComp

  • Backer
  • *
  • Posts: 541
  • Thanks: 1
  • Registered : 05/08/2014
    YearsYearsYearsYearsYearsYearsYearsYears
Re: R83 Feedback / Issues
« Reply #51 on: January 09, 2016, 11:19:28 pm »
It appears you are correct in that, though wouldn't I expect the lights to always be turning on every time the rule is evaluated? Which they are not, only during the initial activation of the rule does it evaluate true.

I do not kick on Away mode every time yet. Getting there,but not yet...too many false alarms.
Kickstarter Backer
Securifi Wiki Editor and Beta Tester, Not a Securifi employee
Almond+, many sensors, IOS App, Android Apps and Widgets

Offline fillibar

  • Backer
  • *
  • Posts: 2060
  • Thanks: 4
  • Registered : 02/08/2013
    YearsYearsYearsYearsYearsYearsYearsYearsYears
Re: R83 Feedback / Issues
« Reply #52 on: January 10, 2016, 08:28:35 am »
If the device remains on the network, I do not know that it would trigger again. But I think you are right. If it is joined and between those times, every rule validation should turn the lights back on set home mode. Interesting that it does not. I really do not know. Someone from Securifi would have to answer that because the behavior does not exactly match a presence sensor and the time range method.
Almond 3 mesh handling the home.

Offline barntacular

  • Beta Testers
  • *
  • Posts: 19
  • Thanks: 0
  • Registered : 01/10/2014
    YearsYearsYearsYearsYearsYearsYearsYears
Re: R83 Feedback / Issues
« Reply #53 on: January 10, 2016, 10:50:14 am »
This is actually an issue that I had reported prior to the most recent firmware release.  Their development staff claimed it was actually not an issue.  IMO something is definitely not right.  The terminology "JOINS" implies that the rule will execute the instant that the device joins.  What is happening is that the rule will execute anytime the device is present on the network.  I recommended changing the terminology from JOINS to ACTIVE or PRESENT.  The last update I received on this was that my feedback was passed on to the appropriate team.

Offline fillibar

  • Backer
  • *
  • Posts: 2060
  • Thanks: 4
  • Registered : 02/08/2013
    YearsYearsYearsYearsYearsYearsYearsYearsYears
Re: R83 Feedback / Issues
« Reply #54 on: January 10, 2016, 12:12:09 pm »
@barntacular:
That is something I am aware of and can be explained as they are being used as presence sensors... So it should activate while they are still around. Although I would also appreciate an immediate, one time option like you mention. The trouble I see with SecureComp's setup is that it triggers at 6am while the device is still on the network but does not continue to trigger. Like it is only being evaluated at the 6am setting unless the device really does leave and rejoin the network.
Almond 3 mesh handling the home.

Offline Paholainen

  • Newbie
  • ***
  • Posts: 39
  • Thanks: 0
  • Registered : 02/11/2014
    YearsYearsYearsYearsYearsYearsYearsYears
Re: R83 Feedback / Issues
« Reply #55 on: January 10, 2016, 05:01:17 pm »
I can send the log files . it has been acting strange every day with the motion trigger. Like I explained if I walk by the sensor shortly after the light has turned OFF it won't come back ON again directly.



@ Paholainen,

Yes, and as per the log files we did not find any issue with the Fibaro. Is it possible for you to remove and add the Fibaro once and check.

See if you can replicate the issue with the Rules and then send the log files which would give us some information on what is causing it.

Offline SecureComp

  • Backer
  • *
  • Posts: 541
  • Thanks: 1
  • Registered : 05/08/2014
    YearsYearsYearsYearsYearsYearsYearsYears
Re: R83 Feedback / Issues
« Reply #56 on: January 10, 2016, 06:13:23 pm »
I think what I'll do is setup my Rule to trigger between time, if X joins and if light xyz is on. Light xyz will only be one if I leave the house, turned on by the leave the house rule.  Light xyz will be off during the night because I'm sleeping.  Will play around with that.

Or, this may force me to finish up my Home/Away testing and work out that last little bugs for my sirens and strobe lights.
Kickstarter Backer
Securifi Wiki Editor and Beta Tester, Not a Securifi employee
Almond+, many sensors, IOS App, Android Apps and Widgets

Offline Ashok

  • Securifi Staff
  • *
  • Posts: 2770
  • Thanks: 3
  • Registered : 25/07/2014
    YearsYearsYearsYearsYearsYearsYearsYears
Re: R83 Feedback / Issues
« Reply #57 on: January 11, 2016, 08:20:44 am »
@ SecureComp,

ISSUE with RULES:
(Rule #30) in my case
Have a Rule setup to Turn on Lights IF Between 6AM-3:59PM AND Device X Joins THEN Turn ON a bunch of Inside Lights, Turn OFF Outside Lights, Set Mode to Home

Expected Result:
Arrive home anytime between 6AM-3:59PM, smartphone joins network, lights set, Home mode set.

What IS Happening:
Every morning at 6AM, All my lights are turning ON and outside lights are turning OFF. (smartphone has been connected to network all night)
Also
Rule works for when I arrive home anytime between 6-3:59, it's just all the lights coming on every day a 6AM that's a problem.

Sending logs tagged "@securecomp waking up every day at 6 because lights on"

snip from runRule.log
Code: [Select]
[2016-1-9 6:0:1.283793437] {PRINT} <================================runRule started=================================>
[2016-1-9 6:0:1.297905849] {PRINT} False in the range1
[2016-1-9 6:0:1.307612622] {PRINT} executing Rule 30 for AND condition is success
[2016-1-9 6:0:1.307789036] {PRINT} setting Job after 1 seconds for Rule 30 Result 1

This is a normal behaviour because your device is already in the network and we are using "AND" Condition in the rule. However, we are planning to change the terminology of network devices in Rules.

Offline Ashok

  • Securifi Staff
  • *
  • Posts: 2770
  • Thanks: 3
  • Registered : 25/07/2014
    YearsYearsYearsYearsYearsYearsYearsYears
Re: R83 Feedback / Issues
« Reply #58 on: January 11, 2016, 08:23:43 am »
@ barntacular,

This is actually an issue that I had reported prior to the most recent firmware release.  Their development staff claimed it was actually not an issue.  IMO something is definitely not right.  The terminology "JOINS" implies that the rule will execute the instant that the device joins.  What is happening is that the rule will execute anytime the device is present on the network.  I recommended changing the terminology from JOINS to ACTIVE or PRESENT.  The last update I received on this was that my feedback was passed on to the appropriate team.

Yes, our team has already accepted the feedback and we are working on changing the terminology of network devices state in Rules.

Offline SecureComp

  • Backer
  • *
  • Posts: 541
  • Thanks: 1
  • Registered : 05/08/2014
    YearsYearsYearsYearsYearsYearsYearsYears
Re: R83 Feedback / Issues
« Reply #59 on: January 11, 2016, 12:33:31 pm »
@ barntacular,

Yes, our team has already accepted the feedback and we are working on changing the terminology of network devices state in Rules.

Excellent, appreciate it.

Another item for the "wish" list, an Event that is Triggered by the Joining of a Device, instead of the Presence of a  Device.

I will be able to create a work around using the "presence" of a device but it would be convenient to have a "joined" device trigger. Would love to have a look at the logic of the Rules Engine because you are close to having exactly what I need.  The goal is being able to trigger events based on the arrival of different devices with variations based on time of day.
Kickstarter Backer
Securifi Wiki Editor and Beta Tester, Not a Securifi employee
Almond+, many sensors, IOS App, Android Apps and Widgets

 

Page created in 0.075 seconds with 19 queries.

bottleneck