2
Choose style:

Author Topic: What's the best way to troubleshoot why rules aren't triggering?  (Read 78 times)

0 Members and 1 Guest are viewing this topic.

Offline AGuardUser

  • Newbie
  • *
  • Posts: 8
  • Thanks: 0
  • Registered : 23/10/2018
    Years
What's the best way to troubleshoot why rules aren't triggering?
« on: September 04, 2019, 12:35:42 am »
I've added some new SYLVANIA LIGHTIFY ZigBee Soft White Dimmable LED bulbs to my setup and while I can control the bulbs from the app, the rules I've setup for them don't seem to be triggering.  At first I thought it was because I was using a sunset rule, but I just tried a time based rule and that didn't seem to work either.  S3 says it has the latest firmware (A3S-R005-64MB).  What do I check first?

Offline vikas jilla

  • Securifi Staff
  • *
  • Posts: 42
  • Thanks: 0
  • Registered : 27/09/2016
    YearsYearsYears
Re: What's the best way to troubleshoot why rules aren't triggering?
« Reply #1 on: September 05, 2019, 12:07:21 am »
Hi,

You could try the following:
  • First you could try to control the DIMMABLE LED Bulb from devices screen
  • If you are able to control from devices screen, then you could try creating a rule where the IF section will have A3S LED set to ON(not the bulb but the LED in A3S) and in THEN Section you could set some DIMMABLE LED BULB function, if this isn't working please do send logs with title "Rules not working".
  • If the above step works, then you could set a rule where IF section will have time set to the next minute and THEN section will have some DIMMABLE LED BULB function, if this isn't working do send logs with "Rules not working with time triggers"

Offline AGuardUser

  • Newbie
  • *
  • Posts: 8
  • Thanks: 0
  • Registered : 23/10/2018
    Years
Re: What's the best way to troubleshoot why rules aren't triggering?
« Reply #2 on: September 08, 2019, 11:49:14 pm »
Thanks Vikas!  Interestingly enough the first bulb I tested worked for all 3 of those cases, though when I tried to change from a time to sunset the rule never seemed to trigger.  Then for another bulb (same brand, model, etc.) the first 2 cases worked, but the timed rule (and the sunset rule) did not.  I'll send logs...

Offline vikas jilla

  • Securifi Staff
  • *
  • Posts: 42
  • Thanks: 0
  • Registered : 27/09/2016
    YearsYearsYears
Re: What's the best way to troubleshoot why rules aren't triggering?
« Reply #3 on: September 10, 2019, 12:07:59 am »
Hi @AGuardUser

Welcome.

We will check the logs, thank you.

And as you said the timed rule worked for the first bulb and didn't work for the second one. Is there any chance that the second bulb didn't have power supply at the time of triggering?

 

Page created in 0.091 seconds with 22 queries.

bottleneck