bottleneck
Choose style:

Author Topic: Enable one WiFi Routed interface on a bridge mode almond+  (Read 316 times)

0 Members and 1 Guest are viewing this topic.

Offline ridernf

  • Newbie
  • *
  • Posts: 8
  • Thanks: 0
  • Registered : 24/05/2017
    YearsYears
Enable one WiFi Routed interface on a bridge mode almond+
« on: November 16, 2019, 09:18:50 am »
Ok so the background is that I have a Samsung Smart TV and my Almond+ in plain transparent bridge mode doesn't work with the TV because it must block some packets or whatever - The Samsung TV fails to do the Gateway test and this causes the apps to say they are not connected to the internet - Although they are (if I go to the browser I can browse the internet fine)

Appears that the solution is to disable "repeater in bridge mode" and make it route between LAN and WAN.

Now the problem is that I have a device connected to one of the Wired Ports that I want on the "WAN side" (which in fact is my LAN.

This could be an easy one if I could bridge the port where my physical device is connected to the WAN port (sta_wlan100) but apparently this is not possible or I couldn't find what interface that port corresponds to

The other option was to keep the device in bridge mode and add an interface where I would attach the Wireless 2.4G and I would connect the TV to it. So all the interfaces would be in bridge mode and sharing the IP addresses of my LAN but I would then create this second interface, enable DHCP on it and route / masquerade to the LAN part ...

This last option would work for me ... if it worked :)

What I have done - I created an interface and attached the WiFi 2.4G to it, enabled DHCP and did my firewall config to allow it to send packets to the rest of the world - The problem is that when I try to connect a wireless device to it I don't get an IP Address

I believe this is because the only interface in there is really the wireless 2.4 and I need to have it bridged to something physical ?

Can someone please help me on this ?

Or, if someone managed to find out why Samsung Smart TV has the problem described above in bridge mode and knows how to fix it ?

Bottom line is
1- I need one wireless interface in routing mode so that I can connect my Samsung TV to it and it detects it is connected to the Internet
2- All the other interfaces (or at least that one specific physical port) on the "other side" on the LAN

Thanks all

/nuno

Offline ridernf

  • Newbie
  • *
  • Posts: 8
  • Thanks: 0
  • Registered : 24/05/2017
    YearsYears
Re: Enable one WiFi Routed interface on a bridge mode almond+
« Reply #1 on: November 16, 2019, 02:44:26 pm »
I found this https://openwrt.org/docs/guide-user/network/wifi/routedap

Which is what I want but after following it and trying to connect to my new wifi I can't get IP address

Any ideas ?

Thanks

 

Page created in 0.061 seconds with 24 queries.