Securifi Community Forum

Securifi Products => Almond 3S => Topic started by: Tokyo on September 08, 2018, 07:11:45 am

Title: Unable to access local / web interface on Almond 3S
Post by: Tokyo on September 08, 2018, 07:11:45 am
I have enabled the web interface on the Almond 3S and confirmed it is enable both on the Almond 3S UI and Almond app.


Note that Fing confirms the IP address of the Almond 3S.
Title: Re: Unable to access local / web interface on Almond 3S
Post by: Ashok on September 08, 2018, 12:56:56 pm
@ Tokyo,

What mode are you using the Almond 3S and the software version?
Title: Re: Unable to access local / web interface on Almond 3S
Post by: Tokyo on September 09, 2018, 03:17:43 am
I am running the Almond 3S in Access Point mode.

The firmware version is A3S-R005-64MB.

Title: Re: Unable to access local / web interface on Almond 3S
Post by: Tokyo on September 09, 2018, 03:56:08 am
I have now configured the Almond 3S in Router mode and I can access router locally through the app and web interface.

It seems not possible when in Access Point or Bridge mode. Not sure whether this is the way it is supposed to work this way, but having the settings available in these mode would suggest it should be possible.
Title: Re: Unable to access local / web interface on Almond 3S
Post by: Ashok on September 10, 2018, 01:22:48 pm
@ Tokyo,

I have now configured the Almond 3S in Router mode and I can access router locally through the app and web interface.

It seems not possible when in Access Point or Bridge mode. Not sure whether this is the way it is supposed to work this way, but having the settings available in these mode would suggest it should be possible.

Web UI and the Local connection should work just fine, even in the Access point mode, all we need to ensure is the device on which we are trying to access is connected to Almond.
Title: Re: Unable to access local / web interface on Almond 3S
Post by: knitnerd on September 15, 2018, 02:26:35 pm
Iím noticing the same problem, but it only cropped up when I viewed the Local connection screen in the mobile app on my iPhone.
It took the second and third character out of the password after that. I tried resetting it and it replaced the second and third character with an =
I can no longer connect locally in the app, but I set the password from the touch screen and now I can login from the web portal. If I try the password in the mobile app, it doesnít work.
Title: Re: Unable to access local / web interface on Almond 3S
Post by: knitnerd on September 15, 2018, 02:30:08 pm
I used the advanced router features screen in the app to reset the local admin password and the local connection now works again.
Title: Re: Unable to access local / web interface on Almond 3S
Post by: Tokyo on September 15, 2018, 09:54:55 pm
I have tested this again. While it works fine inrouter mode, it does not work in access mode. As I mentioned. Previously, a port scan does not show any open ports, including http or https.
Title: Re: Unable to access local / web interface on Almond 3S
Post by: mparadis on September 17, 2018, 07:34:05 am
Strange. Just to check, when you set it up as a access point can you go into the app / LCD and make sure the web interface is set to be available?
Title: Re: Unable to access local / web interface on Almond 3S
Post by: Tokyo on September 23, 2018, 01:19:14 am
The web interface is enabled. It works in router mode, but not in access point mode.
Title: Re: Unable to access local / web interface on Almond 3S
Post by: Ashok on September 27, 2018, 06:25:07 pm
@ Tokyo,

The web interface is enabled. It works in router mode, but not in access point mode.

I just tested it at my desk Almond 3S and Web UI does work in Access point mode. Could you please check the IP address on the Almond 3S and also the IP address on the client device through which you are trying to access the Web UI?
Title: Re: Unable to access local / web interface on Almond 3S
Post by: AGuardUser on October 23, 2018, 12:51:57 am
@Tokyo Did you ever get this to work?  I believe I'm having the same problem in Range Extender mode...
Title: Re: Unable to access local / web interface on Almond 3S
Post by: Ashok on October 23, 2018, 08:14:40 am
@ AGuardUser,

Web UI gets disabled, everytime the Almond 3S is rebooted or when it gets Armed and Disarmed. Hence, before accessing the Web UI, please ensure that the Web UI is enabled and then access it. And also, check if the Almond 3S is in Bridge mode or Wireless WAN mode.
Title: Re: Unable to access local / web interface on Almond 3S
Post by: pdxsk8r on October 25, 2018, 12:50:54 am
Ashok, that is a good tip.  I was really puzzled why I kept loosing access to the web UI.
Title: Re: Unable to access local / web interface on Almond 3S
Post by: AGuardUser on October 25, 2018, 09:51:59 am
@ AGuardUser,

Web UI gets disabled, everytime the Almond 3S is rebooted or when it gets Armed and Disarmed. Hence, before accessing the Web UI, please ensure that the Web UI is enabled and then access it. And also, check if the Almond 3S is in Bridge mode or Wireless WAN mode.

@Ashok Thanks -- anyway that (the disabling of the WebUI) can be disabled?  I was hoping to be able to use the local only interface alone (no cloud), but the doesn't seem feasible if I have to re-enable it all the time (maybe after reboot is OK, but after arm/disarm that's going to get painful).  I'm currently using the bridge mode of the range extender...
Title: Re: Unable to access local / web interface on Almond 3S
Post by: AGuardUser on October 26, 2018, 10:13:35 pm
For the record, I switched to wireless WAN mode and I was able to connect locally!  For the record, Is that not possible in bridged mode?
Title: Re: Unable to access local / web interface on Almond 3S
Post by: Ashok on October 29, 2018, 08:46:06 am
@ AGuardUser,

For the record, I switched to wireless WAN mode and I was able to connect locally!  For the record, Is that not possible in bridged mode?

There is no specific restriction or blocking Web UI in Range Extender mode, as long as the device is connected to the same network, should be able to access the Web UI with out any concerns.