bottleneck
Choose style:

Author Topic: Almond blocking Ubuntu Server website?  (Read 4028 times)

0 Members and 1 Guest are viewing this topic.

Offline Sanborn

  • Acorn
  • *
  • Posts: 6
  • Thanks: 0
  • Registered : 21/01/2014
    YearsYearsYearsYearsYears
Almond blocking Ubuntu Server website?
« on: January 21, 2014, 09:07:51 pm »
I recently put together a server machine with LEMP (Linux, Nginx, MySQL, PHP) and I for the life of me cannot access it externally. I've got port 80 of the Ubuntu server forwarded in Almond, but all I get is ""Oops! Google Chrome could not connect to xxx".

This is actually my second server OS rebuild, the first uses LAMP (apache instead of Nginx) and strangely I could get the page to load about 20% of the time but it was broken...like the website code was only being partially loaded.

canyouseeme.org reports no issues: "Success: I can see your service on XX.XX.XX.XXX on port (80) Your ISP is not blocking port 80"

So I really don't know what to do, and bypassing my router or trying a second router are out of the question. I know there is an open issue with Virtual Servers, is there also an issue with Port Forwarding?

I really don't believe it is my server config, just to get that out there.
« Last Edit: January 22, 2014, 12:46:28 am by Patrick Wilson »

Offline Patrick Wilson

  • Cashew
  • ****
  • Posts: 220
  • Thanks: 0
  • Registered : 21/07/2013
    YearsYearsYearsYearsYearsYears
Re: Almond blocking Ubuntu Server website?
« Reply #1 on: January 22, 2014, 12:57:09 am »
I recently put together a server machine with LEMP (Linux, Nginx, MySQL, PHP) and I for the life of me cannot access it externally. I've got port 80 of the Ubuntu server forwarded in Almond, but all I get is ""Oops! Google Chrome could not connect to xxx".

This is actually my second server OS rebuild, the first uses LAMP (apache instead of Nginx) and strangely I could get the page to load about 20% of the time but it was broken...like the website code was only being partially loaded.

canyouseeme.org reports no issues: "Success: I can see your service on XX.XX.XX.XXX on port (80) Your ISP is not blocking port 80"

So I really don't know what to do, and bypassing my router or trying a second router are out of the question. I know there is an open issue with Virtual Servers, is there also an issue with Port Forwarding?

I really don't believe it is my server config, just to get that out there.

It works remotely.  (Please do NOT publish your external IP address or FQDN (Fully Qualified Domain Name)  in Community Forums.  It attracts Hackers/Spammers to attack your IP).
(I edited your original post to obscure it for your protection - PMW)

Here is what I saw....


(Please note: I obscured your FQDN in this screenshot). 

I'm glad you got it working.  Please share with the community what the issue was.   




« Last Edit: January 22, 2014, 01:01:01 am by Patrick Wilson »
Patrick Wilson
Victoria, BC Canada

Offline Sanborn

  • Acorn
  • *
  • Posts: 6
  • Thanks: 0
  • Registered : 21/01/2014
    YearsYearsYearsYearsYears
Re: Almond blocking Ubuntu Server website?
« Reply #2 on: January 22, 2014, 08:04:55 am »
Thanks for covering me up.

That unfortunately is not how the page should look. It looks very different when I load it internally... im so confused.

Offline Patrick Wilson

  • Cashew
  • ****
  • Posts: 220
  • Thanks: 0
  • Registered : 21/07/2013
    YearsYearsYearsYearsYearsYears
Re: Almond blocking Ubuntu Server website?
« Reply #3 on: January 22, 2014, 11:51:58 am »
Thanks for covering me up.

That unfortunately is not how the page should look. It looks very different when I load it internally... im so confused.

Unfortunately that is a Ubuntu/Wordpress issue at this point.  It works remotely,  in that it successfully reaches your WordPress Website,  however there do indeed seem to be issues with your WordPress configuration.  I note that it provides "hard-coded" URL's which included links to 10.10.10.xxx/24 addresses which should never be present. 

As you want your WordPress site to be accessible access both locally within your 10.10.10.0/24 network,  and on your XXX.XX.XX.XX external IP address,  you will need your WordPress site to use "relative" URL's rather than "explicit" ones which references to your internal network. (I am an Ubuntu user,  but I do not use WordPress at all,  so I can not help you with this part of the problem). 

Discussion of WordPress would be off-topic here anyway.  Perhaps Google or some of the WordPress Support resources on the Internet can assist you further.  I'm afraid with the pending release of our new Almond+ product,  I've haven't had a chance yet to check whether or not our original Almond supports NAT Loopback properly or not. 

If "NAT Loopback" is supported,  then you can probably "hardcode" your Links using your FQDN,  rather than your internal 10.10.10.0/24 network address. My Almond is presently setup as an "Access Point" rather than as my "main Router",  so I can't easily test this right now.  (I will be switching my Network over to my new Almond+ as my main Router,  when it gets here,  so I will try to temporarily setup my original Almond as a Router,  at that time so that I can test "NAT Loopback" compatibility for you at that time. 

If our Almond product does not support "NAT Loopback",  it will probably require changes to the Firmware to support it properly,  but the Almond already has the binaries required to support it,  so I'm sure this can be resolved in time if it isn't already supported.  Unfortunately very few consumer-grade Routers (from any manufacturer) support NAT Loopback correctly,  (possibly including our Almond),  so this frustrating issue affects a lot of people that want to support "external" access to "internal Websites" hidden behind their NAT Routers. 

Please seek assistance with WordPress using appropriate WordPress resources on the Internet.  (Please reply within this message thread if you get it working,  and I will investigate our "NAT Loopback" functionality as soon as I possibly can.  Unfortunately I can't easily switch Routers here without affecting other users on my "home" network,  so I can not promise to "test" this quickly for you. 

I should have my Almond+ Beta product in the coming weeks,  so I will be happy to investigate this properly for you at that time. 



 
Patrick Wilson
Victoria, BC Canada

Offline Sanborn

  • Acorn
  • *
  • Posts: 6
  • Thanks: 0
  • Registered : 21/01/2014
    YearsYearsYearsYearsYears
Re: Almond blocking Ubuntu Server website?
« Reply #4 on: January 22, 2014, 11:21:11 pm »
This was directly a problem with WordPress, you are correct.

As soon as I found the Settings -> General page I noticed there were two URL fields that were set to my internal IP address.

You were ALSO correct about there being a NAT loopback issue, because I can no longer access my site internally but it now works externally. ([Link removed by Admin]). This presents a real issue since I need to access the site internally to write to the blog, not sure what to do about that right now.

Thank you Patrick.
« Last Edit: January 23, 2014, 02:50:22 am by Lars »

LGNilsson

  • Guest
Re: Almond blocking Ubuntu Server website?
« Reply #5 on: January 23, 2014, 02:52:44 am »
Hi Sanborn,

Please refrain from posting public IP addresses and domain names in the forums, especially in cases like this where you haven't fully implemented security features on your site (my assumption in this case), as it's bait for hackers and spammers. Running a few wordpress sites myself, as well as helping some friends of mine, it's easy to get both hacked or have malicious code injected as well as getting a lot of spam if you don't secure your wordpress blog.

Offline Sanborn

  • Acorn
  • *
  • Posts: 6
  • Thanks: 0
  • Registered : 21/01/2014
    YearsYearsYearsYearsYears
Re: Almond blocking Ubuntu Server website?
« Reply #6 on: January 23, 2014, 06:37:46 am »
Roger that, thank you Lars.

 

Page created in 0.168 seconds with 24 queries.

bottleneck